Home > An Error > Unable To Locate Package Libmysql-ruby

Unable To Locate Package Libmysql-ruby

Contents

what was I going to say again? How can tilting a N64 cartridge cause such subtle glitches? How to NOT render a part of a document The 10'000 year skyscraper What is really curved, spacetime, or simply the coordinate lines? Tried that before posting the question and still does not work. –penne12 Mar 7 '15 at 17:10 ran: \curl -sSL https://get.rvm.io | bash -s stable --ruby –penne12 Mar 7 http://kshelper.com/an-error/an-error-occurred-cannot-parse-message-json-file-from-uploaded-package.html

It's a little disappointing that old versions of ruby-devel don't have a dependency on g++. Make sure that `gem install mysql2 -v '0.3.17'` succeeds before bundling. Another issue may be that the MySQL development libraries aren't installed. Determine maximum frequency of input signal to make system LTI Guessing game - Is it a 40?

Unable To Locate Package Libmysql-ruby

Can I get a dual entry Schengen visa for tourism purpose for me and my wife? Wait let me say it again for those of you who don't believe me. Safely adding insecure devices to my home network Why had Dumbledore accepted Lupin's resignation?

Specifying an older mysql2 gem (eg v0.3.x) fixes the issue: gem 'mysql2', '~> 0.3.21' Source: https://github.com/brianmario/mysql2/issues/675 share|improve this answer answered May 28 at 5:51 GG Crew 113 add a comment| Your The funny thing is that MySQL 6.0 hasn't been invented yet. This gem was compiled for 6.0.0 but the client library is 5.0.27. ... An Error Occurred While Installing Mysql2 (0.3.20), And Bundler Cannot Continue. yes checking for rb_thread_blocking_region()...

asked 1 year ago viewed 4032 times active 1 year ago Linked 382 Error installing mysql2: Failed to build gem native extension Related 382Error installing mysql2: Failed to build gem native An Error Occurred While Installing Sqlite3 (1.3.10), And Bundler Cannot Continue. You may need configuration options. Is it unethical to poorly translate an exam from Dutch to English and then present it to the English speaking students? http://stackoverflow.com/questions/18840020/an-error-occurred-while-installing-mysql2-0-3-11 Check the mkmf.log file for more details.

Make sure that `gem install mysql2 -v '0.3.11'` succeeds before bundling. An Error Occurred While Installing Mysql2 (0.3.16), And Bundler Cannot Continue. Why did the best potions master have greasy hair? more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed What is the origin of the word "pilko"?

An Error Occurred While Installing Sqlite3 (1.3.10), And Bundler Cannot Continue.

thanks a lot Sign up for free to join this conversation on GitHub. look at this site no checking for main() in -lnsl... Unable To Locate Package Libmysql-ruby Perhaps if you update the installation to use the correct path, it will find the file in the full file path /home4/agtcorp/rails_apps/agtcorp2/Rakefile.' I don't know how to do that. An Error Occurred While Installing Mysql2 Ubuntu We recommend upgrading to the latest Safari, Google Chrome, or Firefox.

So, finally, I opted for working within a virtual workspace. Without opening the PHB, is there a way to know if it's a particular printing? I am using ruby 1.9.3 and Rails 3.2.19 My problem starts here When I try create the application with rails generate [email protected]:~/ruby$ rails new app2 -d mysql create create README.rdoc create if RUBY_PLATFORM =~ /mswin|mingw/ inc, lib = dir_config('mysql') # Ruby versions not incorporating the mkmf fix at # https://bugs.ruby-lang.org/projects/ruby-trunk/repository/revisions/39717 # do not properly search for lib directories, and must be corrected An Error Occurred While Installing Mysql2 (0.3.18), And Bundler Cannot Continue.

Please do not post new questions to unrelated issues, especially ones that are already closed. White ring of pus forming around branches How do I sort files into a sub-folder based on filename part? Environment: rails version - 4.2.6 , ruby - 2.3, mysql - 5.7 ruby-on-rails rubygems share|improve this question edited Jul 27 at 11:39 asked Jul 27 at 11:16 Yuvisiva 11 Join them; it only takes a minute: Sign up Error bundle install - “mysql2” [duplicate] up vote 2 down vote favorite This question already has an answer here: Error installing mysql2:

yes checking for mysql_query() in -lmysqlclient... Make Sure That Gem Install Mysql2 Succeeds Before Bundling Resolving dependencies... Jaime Young 8,110 Points Jaime Young Jaime Young 8,110 Points over 1 year ago Hi I installed the mysql2 gem properly but when I input rake db:create, it still creates an

Any ideas why the command won't complete would be greatly appreciated!

share|improve this answer answered Aug 11 at 12:40 ymbirtt 4731316 add a comment| Your Answer draft saved draft discarded Sign up or log in Sign up using Google Sign up What is really curved, spacetime, or simply the coordinate lines? yes checking for mysql_query() in -lmysqlclient... An Error Occurred While Installing Mysql2 0.3 19 And Bundler Cannot Continue no checking for main() in -lm...

no checking for rb_wait_for_single_fd()... Is it acceptable to ask an unknown professor for help in a related field during his office hours? asked 1 year ago viewed 4032 times active 5 months ago Get the weekly newsletter! I have an existing 2.1.2 installation that I'm trying to upgrade with some new features.

Make sure that `gem install mysql2 -v '0.3.18'` succeeds before bundling. Results logged to /Users/Ben/.rvm/gems/ruby-2.2.0/extensions/x86_64-darwin-14/2.2.0/mysql2-0.3.18/gem_make.out An error occurred while installing mysql2 (0.3.18), and Bundler cannot continue. While it is possible to get a very simple Rails app up and running on Hostgator with a great deal of effort and hair-pulling, you would likely be far better served How did early mathematicians make it without Set theory?

In the Migrations video in Stage 2, the project is created using rails new biller -d mysql However, when I try I get an error when it tries to install mysql Depalindromize this string! no checking for main() in -lnsl... Can't figure out what it is.

Suspicious lines from mkmf.log (can C compile code with errors, not merely warnings?): have_func: checking for rb_wait_for_single_fd()... -------------------- yes "gcc -o conftest -IC:/Apps/Ruby/Ruby193/include/ruby-1.9.1/i386-mingw32 -IC:/Apps/Ruby/Ruby193/include/ruby-1.9.1/ruby/backward -IC:/Apps/Ruby/Ruby193/include/ruby-1.9.1 -I. -DFD_SETSIZE=2048 -DFD_SETSIZE=2048 -O3 -fno-omit-frame-pointer -g Add-in salt to injury? Browse other questions tagged ruby-on-rails ruby or ask your own question. I'm stuck on this, tried uninstalling mysql2 gem, reinstalling, keep getting errormkmf.rb:381:in `try_do': The compiler failed to generate an executable file. (RuntimeError) You have to install development tools first. –bjm88 Dec

Windows 7 Ultimate 64-bit (6.1 build 7601 SP1)Ruby 1.9.3p448 (2013-06-27) [i386-mingw32]Rails 3.2.13MySQL 5.5.25.0 Any suggestions? more stack exchange communities company blog Stack Exchange Inbox Reputation and Badges sign up log in tour help Tour Start here for a quick overview of the site Help Center Detailed no checking for main() in -lz... Personal Open source Business Explore Sign up Sign in Pricing Blog Support Search GitHub This repository Watch 77 Star 1,529 Fork 343 brianmario/mysql2 Code Issues 36 Pull requests 10 Projects

I run follow bundle I got the error An error occurred while installing mysql2 (0.3.11), and Bundler cannot continue. It will give you the errors –j-dexx Jul 27 at 12:00 add a comment| 1 Answer 1 active oldest votes up vote 0 down vote Try this sudo apt-get install libmysqlclient-dev